Bijna alle Intel-GPU's in Ivy Bridge- tot en met Coffee Lake-CPU's vatbaar voor bug

66 reacties

Phoronix heeft ontdekt dat Intel-gpu's van Gen7, Gen7,5 en Gen9 vatbaar zijn voor een beveiligingsbug, het bedrijf heeft al patches uitgerold om het probleem op te lossen. De achtste generatie blijkt niet vatbaar te zijn, dankzij een eerdere softwarefix.

De nieuwe bug heeft de naam CVE-2019-14615 en houdt in dat 'in bepaalde datastructuren de toestroom van data niet kan worden gecontroleerd'. Een kwaadwillende kan zo via local access toegang krijgen tot data die wordt verwerkt, dat overigens wel een vereiste is om in te breken.

Een Intel Core-die van de Ivy Bridge-generatie, de eerste generatie chips die last hebben van dit probleem. Vanaf Ice Lake is dit probleem verholpen.

De workaround voor de nieuwere Gen9-producten houdt in dat de execution state tussen de contextschakelaars wordt verwijderd. Bij Haswell en Ivy Bridge worden de Unified Resource Buffer en de execution units geleegd door een custom kernel voor deze eu's aan te spreken. Ook Valley View is kwetsbaar, deze Atom-processors maken gebruik van dezelfde Gen7-gpu's als Ivy Bridge.

De drivers van de negende generatie hebben inmiddels de fix ontvangen, de oudere processors nog niet. Van deze producten wordt nog bekeken wat de prestatie-impact precies is.

Bronnen: Phoronix (1), (2)

« Vorig bericht Volgend bericht »
0
*