Bootloader-bug vormt probleem voor alle apparaten met UEFI Secure Boot

9 reacties

Een beveiligingsbedrijf genaamd Eclypsium heeft een bug gevonden in grub2, een belangrijke tool die de bootloader gebruikt door uefi Secure Boot-functionaliteit.

Secure Boot maakt gebruik van een pakketje genaamd grub2 (de grand unified bootloader) dat aanwezig is in de meeste Linux-distributies. Windows maakt er ook gebruik van, zolang Microsoft zelf de autoriteit is voor beveiligingscertificaten - dat is bij vrijwel alle Windows-producten het geval. Voor Linux zijn vrijwel alle grub2-beveiligingscertificaten getroffen, waardoor praktisch alle Linux-distributies kwetsbaar zijn.

De bug heeft het kenmerk CVE-2020-10713 ontvangen en draagt de naam BootHole. Het gaat volgens de CVE om een relatief ernstig probleem en krijgt een CVSS-score van 8.2. BootHole maakt het mogelijk om tijdens het opstartproces malafide software uit te voeren, ook als grub2 niet gebruikt wordt. Eenmaal geïnstalleerd moeten heimelijke bootkits bijna volledige controle over het geïnfecteerde apparaat mogelijk maken. Volgens Eclypsium gaat het om een configuratiebestand genaamd grub.cfg, dat los staat van grub2 zelf. Door de waarden in dit bestand aan te passen kan een buffer overflow worden veroorzaakt om de aanvaller de controle te geven.

Volgens Ubuntu-ontwikkelaar Canonical zijn er ook zeven gerelateerde bugs met elk hun eigen CVSS-benamingen. Het aantal fabrikanten dat patches uitbrengt voor de kwetsbaarheden neemt toe, met momenteel tientallen fabrikanten die het probleem hebben verholpen. Red Hat zegt wel dat het probleem moeilijk uitvoerbaar is.

Bronnen: CVE, Eclypsium, Canonical, Red Hat

« Vorig bericht Volgend bericht »
0
*