Update: Microsoft breidt TPM 2.0-vereiste in Windows 11 uit naar virtuele machines

23 reacties

Microsoft heeft een nieuwe Windows 11-build in de bètafase beschikbaar gesteld. Naast de nodige oplossingen voor bekende problemen vereist de build een tpm 2.0-module als je virtual machines gebruikt. De update heet Insider Preview Build 22000.194.

Daarmee zijn de tpm-vereisten voor virtuele machines gelijk aan die van reguliere systemen. Eerder dit jaar waren er een hoop twijfels en onduidelijkheden of dit wel een harde eis ging zijn voor het nieuwe besturingssysteem, maar niet veel later maakte Microsoft bekend dat tpm 2.0-modules inderdaad een vereiste zijn. In de Hyper-V-hypervisor dienen de virtuele machines onder de tweede generatie te vallen.

Verder is een probleem met Bluetooth-apparaten opgelost, dat ervoor zorgde dat gebruikers na het verliezen van de verbinding niet meer in staat waren om hun Bluetooth-apparaten te gebruiken met Windows. Het uitschakelen van thema's met een bepaald contrast had als gevolg dat sommige knoppen en titelbalken niet meer goed zichtbaar waren, ook dit is opgelost.

Als laatste zijn er app-updates voor Knipprogramma, Rekenmachine en Alarm met focus-sessies uitgerold. Laatstgenoemde is in augustus onthuld en maakt het mogelijk om een timer in te stellen tot je volgende pauze, zodat je beter geconcentreerd blijft. Het programma kan ook bijhouden hoe vaak je dit doel haalt.

Update 18-09-2021 (17:01):

In de changelog heeft het bedrijf verder uitgelegd dat de nieuwste Windows 11 preview-build alleen compatibel is met vm's met tpm 2.0-bescherming, een vereiste die ook van toepassing is op laptops en pc's met het nieuwe besturingssysteem. Volgens Microsoft omvat de laatste previewversie een wijziging die de handhaving van de Windows 11-systeemvereisten op virtuele machines gelijk trekt zodat deze hetzelfde is als voor fysieke pc's".

Als gevolg van de aanpassing ontvangen virtuele machines die momenteel oudere Windows 11 preview-builds draaien geen updates meer. Nieuwe Windows 11-sessies die zijn gemaakt met incompatibele vm-software zullen niet werken zoals gewenst.

Momenteel voldoen slechts een paar vm's aan de noodzakelijke vereisten om de nieuwste Windows 11 preview-build en de officiële stabiele versie, die op 5 oktober zal verschijnen, te draaien. VMware Workstation Pro zou ook voldoen aan de nieuwe tpm-vereiste.

Bron: Microsoft

« Vorig bericht Volgend bericht »
0
*